Hugin-2012.0.0 Release Notes

Hugin is more than just a panorama stitcher.

Changes Since 2011.4.0

The lensfun library for reading and writing lens parameters from/to database has now been integrated into Hugin.
Users can now search the lensfun library and load lens parameters.

Added new tool pto_gen for generation of pto file from image files.

Other Improvements


Most of the translations have been updated for this release.


Upgrading from previous versions of Hugin should be seamless. If you do have problems with old settings, these can be reset in the Preferences window by clicking 'Load defaults'.

It is strongly recommended to set the default control point detector to Hugin's CPFind. It is the only control point generator endorsed by Hugin. Third-party generators may be compatible with the plug-in architecture.


Users compiling from source refer to the list of dependencies and the platform-specific build processes described in the wiki. More information in the README and INSTALL_cmake files in the tarball.


Hugin can be found at SourceForge and Launchpad.

Users communities produce executables for their respective platforms. Executables are likely to be announced within a few days of this tarball release on the mailing list and added to the download section on SourceForge.

Known Issues and Workarounds

Panosphere Overview window separated from the content. Details.

Mac OS X:

- Mac OS X Tiger (10.4) is no longer supported.
- The PPC platform is no longer supported.
- The OpenMP enabled enblend is now compatible on Mac OS X Lion (10.7).
- The cmake compilation of Hugin is currently broken due to the fact that
the boost library on OS X is currently at version 1.50 and boost versions => 1.48
conflict with a number of Mac OS X macros (from AssertMacros.h). This can
not be disabled as WxWindows for Mac (a.k.a. WxMac) needs these macros.
An XCode build, where a specific boost (<=1.46) can be specified, is
possible. The 2012.0 OSX bundle will be based on an XCode build with boost

OpenSuse 11.4 has a bug in a used library that results in crashes.

There is a known problem building Hugin with CMake 2.8.5rc2. Workaround: Upgrade to a newer CMake version.

An updated list of issues deemed to be critical, including discussions and workarounds, is in the Issues Tracker.


Thanks to all the contributors to this release and members of the hugin-ptx mailing list, too many to mention here.